Différences entre les versions de « Python/L'interpréteur »

124 octets supprimés ,  il y a 9 ans
m
→‎Sous Linux : diverses corrections
m (→‎Sous Linux : diverses corrections)
 
=== Sous [[w:Linux|Linux]] ===
Python est déjà pré-installé depuis la version Ubuntu 6.04. Pour les autres distributions, s'il ne l'est pas il faut regarder dans les dépôts. Pour vérifier si Python est bien installé, il suffit de lancer dans un terminal :
<source lang="bash">$ python -V # V majuscule</source>
$ python -V # V majuscule
Cette commande vous sortira le numéro de version du Python installé, ou une erreur s'il n'est pas installé.
</source>
Cette commande vous sortiradonnera le numéro de version du Python installé, ou une erreur s'il n'est pas installé.
 
Dans une distribution dubasée typesur UbuntuDebian oucomme debian-basedUbuntu, il suffit d'installer les paquets avec le gestionnaire de paquets ''aptitudeapt'' :
<source lang="bash">
$ sudo apt-get update # Mise à jour des dépôts
</source>
 
Si votre distribution ne possède pas de paquets Python, vous pouvez compiler Python depuis ses sources. Pour cela, il suffit de se rendre sur [http://www.python.org/getit/ http://www.python.org/getit/], puis de suivre les instructions.
 
Attention ensuite à accorder les bons droits d'écriture sur les scripts Python (.py) :
<source lang="bash">
$ sudo chmod +x myscript.py
</source>
 
=== Version installée ===
4 885

modifications