Différences entre les versions de « SPARQL Protocol and RDF Query Language/Travail pratique/Initiation à Eclipse »

* cliquer sur "redémarrer maintenant"
 
===Ouvrir levotre projet PHP dans Eclipse===
==Projet==
Nous avons dans le projet précédent utilisé PHPUnit et créer une arborescence à un projet nommé MonCV.
Nous allons ouvrir ce projet et le configurer.
 
===Ouvrir le projet dans Eclipse===
 
#Ouvrir Eclipse
#cliquer sur Terminer (Finish)
 
===Configurer la construction du projet===
Nous allons utiliser phing pour construire le projet automatiquement pour permettre de le débugger.
 
Cliquer finalement sur le bouton OK pour refermer la boite de dialogue.
 
===Configurer le débuggueur=débugguage==
====Indiquer le serveur utiliser pour débugger====
Nous utiliserons le serveur Web que nous avons installé dans un précédent TP pour débuguer notre projet.
 
====Indiquer le débuggeur====
# Via le Menu : Window > Preferences
# Aller dans le Menu : Window > Preferences
# Cliquer sur le noeud : PHP > Debug
# Cliquer sur appliquer (Apply)
# Cliquer sur OK pour fermer la fenêtre
 
==Débugguer une page Web==
 
=== Créer une page web ===
 
Nous allons créer une page PHP dans le répertoire src :
# Cliquer bouton droit sur le répertoire src dans Eclipse
# Nouveau > PHP File
# Indiquer comme nom de fichier : index.php
 
Insérer le texte suivant dans le fichier :
<source lang="PHP">
<?php
phpinfo();
</source>
 
Sauvegarder en faisant dans le Menu : File > Save (ou Ctrl + s )
 
=== Insérer un point d'arrêt ===
 
Un point d'arrêt est un point placé à un endroit spécifique d'un programme qui permet d'indiquer à un débogueur d'arrêter l'exécution lorsqu'il atteindra cet endroit.
 
C'est très pratique pour voir à cet endroit la valeur des variables ou encore pour commencer à faire du pas à pas dans le code.
Le pas à pas permet d'avancer dans le code "commande par commande". Le pas à pas permet de voir exactement ce qui exécuter par le programme.
 
Pour insérer un point d'arrêt, il suffit de double cliquer sur le numéro de ligne où vous souhaitez que le programme s'arrête. Un point bleu doit apparaitre dans la marge ce qui indique le point d'arrêt.
 
'''Exercice''' : double cliquer sur le numéro de ligne où la fonction phpinfo se trouve.
Ce point d'arrêt nous sera utile dans l'exercice suivant.
 
===Créer un profil de débuggeur===
 
Un site Web est composé de plusieurs fichiers PHP qui peuvent être autant de point d'entrée dans votre site.
Si vous débuguer une page php particulière, il vous faudra créer un profil de débuggage pour cette page.
A chaque fois que vous voudrez débugger une page, vous pourrez réutiliser le profil de cette page que vous avez créé.
 
Nous allons créer un profil de débuggage pour la page index.php.
 
# Via le Menu : Run > Debug configurations
# Cliquer bouton droit sur PHP Web Page
# Dans le menu contextuel choisir Nouveau
# Donner un nom : index.php
# Indiquer le fichier PHP à executer en cliquant sur le bouton chemin et trouver le fichier index.php (ce qui doit donner : /MonCv/src/index.php)
# Décocher : Break at first line (sinon le débuggeur s'arrêtera dès la première ligne)
# Décocher Auto-generate pour indiquer manuellement l'url index.php sur le serveur
# Modifier l'URL '''/MonCv/src/index.php''' en laissant juste '''index.php'''
# Cliquer sur appliquer (Apply) pour sauver
# Cliquer sur fermer (close)
 
{{remarque|contenu= Si la configuration de XDebug s'est bien passée, vous devez lire devant server Debugger : XDebug et devant PHP server : moncv.
Si ce n'est pas le cas, indiquez XDebug et le serveur moncv}}
 
===débugger===
 
Eclipse a plusieurs modes d'affichage. Il y en a un pour PHP et un pour Débugger. Eclipse vous demandera souvent de passer d'un mode à un autre automatiquement.
 
Pour revenir manuellement à un de ces modes, vous pouvez faire menu : Window > Open Perspective > PHP ou Debug.
 
Un bug en anglais signifie insecte ou encore une erreur dans du code informatique. C'est la raison pour laquelle dans Eclipse tout ce qui touche au mode Debug est représenté par un insecte.
 
Nous allons lancer le débugage
#En haut de l'écran (dans la toolbar), il y a un insecte avec un triangle, cliquer sur le triangle
# choisir index.php qui est le profil que nous avons créé.
# Eclipse vous propose de passer en mode Debug : accepter
 
Vous pouvez voir maintenant (si tout c'est bien passé) :
* Zone Debug (en haut à gauche) '''un carré rouge qui vous permet d'arrêter le débugage'''
* Zone Debug (en haut à gauche) '''un triangle vert qui vous permet de poursuivre l’exécution'''
* Zone Debug (en haut à gauche) des flèches jaune qui vous permettent de faire du pas à pas de différents types
* Zone Fichier (au milieu à gauche) vous voyez le fichier avec une flèche bleu
* Zone navigateur (en bas), c'est le navigateur par défaut (qu'on peut modifier dans les préférences) où vous pouvez voir le résultat de l'exécution c'est-à-dire une page web.
 
Vous découvrirez en jouant avec éclipse les milles et une fonction disponible.
 
Vous avez maintenant l'environnement de développement qui va nous permettre de développer un service Web mais surtout de suivre la leçon sur SPARQL.
 
==Premier pas dans Eclipse==
700

modifications