« Introduction aux tableurs avec CALC/Données » : différence entre les versions

m
WPCleaner v1.38b - Corrigé avec P:CS (Caractères de contrôle - Item de liste terminé par un saut de ligne)
m (WPCleaner v1.38b - Corrigé avec P:CS (Caractères de contrôle - Item de liste terminé par un saut de ligne))
*Cliquez sur la cellule où vous souhaitez importer les données du fichier texte.
*Dans l’onglet Data > Cliquez sur A partir du texte
*Dans la nouvelle fenêtre, localisez le fichier que vous désirez importer et cliquez sur Importer<br />
L’assistant d’importation de texte s’affiche, si vous souhaitez importer vos données de façon brute, vous pouvez cliquer directement sur Terminer. Si vous souhaitez configurer l’importation de vos données, il est nécessaire de parcourir toutes les étapes de l’assistant d’importation.
*Dans la nouvelle fenêtre importation de données, vous pouvez cliquer sur Propriétés pour paramétrer certaines options d’importation, ou bien spécifier l’emplacement ou vous souhaitez importer vos données sous «Insérer les données dans»
 
Le tri peut s’effectuer sur une ou plusieurs colonnes, mais également sur une ou plusieurs lignes.
<br /><br />
===Trier une unique colonne===
# Vérifiez que toutes les données de la colonne à trier sont au même format pour éviter les problèmes de tri. Si toutes les données ne sont pas au même format, [[Tableur CALC/Accueil|mettre en forme]](type et format d'affichage) toutes les données de la colonne.
# Si vous avez choisi le tri personnalisé, une boite de dialogue s’ouvre. Vous pouvez alors choisir le type de tri que vous souhaitez effectuer (Valeurs, couleur de la cellule, couleur du texte, icone). Sélectionnez le type de tri puis l’ordre souhaité.
 
<br />
===Trier plusieurs colonnes===
Il y a deux possibilités pour le tri de plusieurs colonnes :
* Tri de plusieurs colonnes avec plusieurs critères : Vous modifiez l’ordre de plusieurs colonnes grâce à un ordre de priorité.
Exemple : Vous souhaitez trier la liste des commandes clients de votre entreprise selon leur nom et la date de leur dernière commande. La priorité est le tri selon le nom, puis si le client a passé plusieurs commandes, celles-ci s’afficheront de la plus récente à la plus ancienne, et non pas dans un ordre aléatoire. C’est le tri sur plusieurs critères.
<br /><br />
=====Tri avec un seul critère=====
# Vérifiez que toutes les données de la colonne à trier sont au même format pour éviter les problèmes de tri.
# Si vous avez choisi le tri personnalisé, une boite de dialogue s’ouvre. Vous pouvez alors choisir le type de tri que vous souhaitez effectuer (Valeurs, couleur de la cellule, couleur du texte, icone). Sélectionnez le type de tri puis l’ordre souhaité.
# Validez en cliquant sur OK : Le tri s’effectue, et les données de chaque ligne suivent.
<br />
=====Tri avec plusieurs critères=====
# Vérifiez que toutes les données de chaque colonne à trier sont au même format pour éviter les problèmes de tri.
# Sélectionnez le type de tri puis l’ordre souhaité pour chacune des colonnes choisies.
# Validez en cliquant sur OK.
<br />
 
===Trier d’après une liste personnalisée===
* Jours de la semaine
* Mois de l’année
<br />
Pour créer une autre liste personnalisée :
# Cliquez sur le bouton Microsoft Office, puis sur Options
# Cliquez sur Entrée à chaque nouvelle saisie de ligne.
# Lorsque votre liste est terminée, cliquez sur Ajouter, puis deux fois sur OK.
<br />
===Trier des lignes===
# Sélectionnez une plage de cellules.
# Effectuez le tri souhaité en choisissant la ligne, le type de tri et l’ordre de tri.
# Cliquez sur OK pour valider.
<br />
===Remarques===
{| class="wikitable"
Le filtre automatique permet de trouver des valeurs, d’afficher ou de masquer des valeurs, sur une ou plusieurs colonnes de données. Vous pouvez filtrer vos données à partir de listes de sélection ou bien en cherchant les valeurs que vous souhaitez afficher. Lorsque vous filtrez vos données, des lignes complètes sont masquées si les valeurs d’une ou plusieurs colonnes ne correspondent pas aux critères des filtres.
* Sélectionnez les données que vous voulez filtrer automatiquement
* Cliquez sur Données > Filtrer<br />
* Cliquez sur la flèche située à côté de l’en-tête de la colonne que vous souhaitez filtrer et faites l’une des actions suivantes :
** Choisissez une valeur spécifique : Cliquez sur (Sélectionner Tout) pour décocher toutes les cases à cocher, et sélectionnez ensuite les valeurs que vous souhaitez afficher pour la colonne concernée.
** Recherchez une valeur : Dans le champ de Recherche, indiquez le texte ou le nombre que vous souhaitez afficher pour la colonne concernée.<br />
* Cliquez sur OK pour appliquer le filtre
 
Dans la feuille de calcul suivante : <br />
*Un filtre est disponible pour la colonne Stock mais n’a pas été utilisé.
*Le filtre dans la colonne Category a été utilisé pour ne pas afficher la category Engine, de ce fait les lignes 8 et 9 sont masquées.<br />
 
 
== Conversion de données ==
La fonction convertir permet de diviser une colonne de donnée texte en plusieurs colonnes. Par exemple vous pouvez à partir d’une colonne nom complet, la diviser en une colonne prénom et une colonne nom de famille.
<br />
 
 
1ère étape : sélectionnez la colonne de texte que vous voulez fractionner puis cliquez sur convertir.
<br />
[[File:Convertir étape 1.png|300px|Convertir étape 1]]<br /><br />
 
2{{e}} étape : la fenêtre « assistant de conversion » s’ouvre alors. Cliquez sur délimiter puis suivant. Cochez ensuite le mode de séparation que vous avez utilisé, par exemple espace. (Vous pouvez également cocher plusieurs modes de séparation si vous avez par exemple utilisé une virgule puis un espace entre vos données à fractionner). Un aperçu de vos données s’affiche en bas de la fenêtre. Cliquez sur suivant.<br /><br />
 
 
<br /><br />
 
3{{e}} étape : Vous pouvez choisir le format de vos nouvelles colonnes, par exemple texte. Ou bien vous pouvez laisser le format prédéfini par CALC. Un aperçu de vos nouvelles données s’affiche en bas de la fenêtre. <br /><br />
 
 
 
<br /><br />
 
4{{e}} étape : Réduisez la fenêtre en cliquant sur le bouton à droite de la ligne destination (situé au milieu de la fenêtre). Sélectionnez les cellules dans lesquelles vous souhaitez coller vos nouvelles données fractionnées. <br /><br />
 
[[File:4eme étape.png|300px|convertir]]
 
<br /><br />
 
5{{e}} étape : Cliquez sur le bouton à droite de la ligne de destination pour agrandir la fenêtre. Cliquez sur terminer.<br /><br />
 
[[File:Convertir étape 5.png|300px|Convertir étape 5]]
# Pour supprimer des doublons, cliquez sur une cellule comprenant des données
# Cliquez sur le bouton « SUPPRIMER LES DOUBLONS »
# La fenêtre suivante apparaît <br /><br /><br /><br />
# Cliquez sur le bouton « SELECTIONNER TOUT » pour sélectionner toutes les colonnes. Ou sur le bouton « DESELECTIONNER TOUT » pour désélectionner les colonnes.<br />​VousVous pouvez choisir manuellement les colonnes dans lesquelles il y a des doublons à supprimer en cochant les colonnes (exemple : Année)<br />​LaLa coche « Mes données ont des en-têtes » fait apparaître le nom des colonnes. Si vous décochez, les colonnes seront nommés « Colonne 1 » pour « Année », « colonne 2 » pour « Modèle » et « colonne 3 » pour « Prix ».<br />
Attention: une donnée dans une même colonne peut avoir été attribuée plusieurs fois, alors que les colonnes adjacentes ne sont pas identiques. Si vous cochez une seule colonne, par exemple "ANNEE", la fonction "SUPPRIMER LES DOUBLONS" effacera toutes les lignes qui ont la même année.
# Cliquez sur le bouton « OK »
# S’il y a un doublon dans votre feuille de données
 
<br />
Alors les données seront supprimées et le message " x valeurs en double trouvées et supprimées. Il reste y valeurs uniques." apparaît.<br /><br />​LeLe doublon est alors supprimé.
<br />
 
== Validation de données ==
La validation des données permet de restreindre la saisie de certaines valeurs ou types de données par les utilisateurs du classeur CALC. Ainsi les utilisateurs ne pourront pas saisir des données qui ne sont pas valides. Ou bien vous pouvez simplement avertir l’utilisateur que ces données ne sont pas valides. Vous pouvez aussi afficher un message d’instruction sur le type de donnée valide afin d’aider l’utilisateur à saisir les données attendues.
<br />
===Utiliser la validation des données===
 
* Restreindre les heures en dehors d’une certaine plage horaire. Par exemple, vous pouvez spécifier une plage horaire correspondant à l’ouverture d’un magasin.
 
<br />
 
Vous pouvez utiliser des formules pour la validation des données. Par exemple pour restreindre une plage entre 1 mois avant la date du jour jusqu'à 1 mois après, entrez la formule =AUJOURDHUI()-30 comme date de début et =AUJOURDHUI()+30 comme date de fin de plage.
 
<br />
 
Vous pouvez utiliser vos formules dans autoriser : personnalisé. Par exemple pour autorisez la mention félicitation uniquement si la moyenne en cellule E2 est supérieure à 16. Dans personnalisé saisissez la formule SI(E2>16;"félicitation").
 
<br />
 
Vous pouvez utiliser le contenu d'une autre cellule pour autoriser les données de votre cellule. Par exemple pour que le contenu de la cellule résultat soit comprise entre le montant négatif des charges en cellule A2 et le montant des produit en cellule B2. Alors dans minimum saisissez =-A2 et en maximum =B2.
 
<br />
Vous pouvez entourer les données non valides en cliquant sur le bouton "entourer les données non valides". Ainsi toutes les données erronées sont entourées par des cercles rouges. Ces cercles disparaissent automatiquement lorsque les données sont corrigées, sinon il suffit de cliquer sur le bouton "effacer les cercles de validation".
 
 
Pour supprimer la validation de données pour une cellule, sélectionnez-la, cliquez sur Validation des données puis effacer tout (dans l'onglet paramètre).
<br />
 
===Messages de validation des données===
 
 
* Message de saisie, il s’affiche lorsque l’utilisateur place son curseur sur la cellule. Il permet de conseiller l’utilisateur sur le type de donnée attendu.<br />​
[[File:Capture d’écran (17).png|Message de saisie]]<br /><br />
 
* Message d’erreur, il s’affiche lorsque l’utilisateur entre des données non valides. Il existe plusieurs types d’alerte.
 
Le type arrêt propose à l’utilisateur de choisir entre recommencer ou annuler ce qui efface la donnée erronée saisie dans la cellule.Ce type de message ne laisse pas la possibilité à l'utilisateur de confirmer qu'il a délibérément entré une donnée non valide. <br /><br />
 
[[File:Capture d’écran (11).png|300px|Message d'avertissement]][[File:Message d'alerte.png|400px|Message d'avertissement]]<br /><br />
 
Le type avertissement laisse trois possibilités à l’utilisateur, "annuler", "non" pour modifier les données saisies et "oui" pour accepter les données non valides.<br /><br />
 
[[File:Capture d’écran (13).png|300px|Message d'avertissement]][[File:Capture d’écran (14).png|400px|Message d'avertissement]]<br /><br />
 
Le type information, l’utilisateur peut choisir "ok" il accepte les données ou annuler. <br /><br />
 
[[File:Capture d’écran (15).png|300px|Message d'avertissement]][[File:Capture d’écran (16).png|400px|Message d'avertissement]]<br /><br />
 
 
Il est possible de personnaliser le message d’erreur, sinon c’est un message par défaut qui s’affiche.<br /><br />
 
Attention, ces messages ne fonctionnent pas pour 3 cas : lorsque la cellule est remplie par copie ou remplissage, lorsque c’est une formule qui calcul les données de la cellule et lorsqu’une macro entre les données dans la cellule. <br /><br />
 
{{Remarque|contenu=lorsque vous définissez des paramètres de validation des données alors que les cellules contiennent déjà des données non valides alors rien ne se passe automatiquement. Il faut mettre en évidence les données non valides en les entourant.}}
<br />
 
===Exemple d'application de la validation des données===
<br />
1ère étape : Sélectionnez une ou plusieurs cellules à valider. Sous l’onglet Données, dans le groupe Outils de données, cliquez sur Validation des données.<br /><br />
2{{e}} étape : Dans « critère de validation » vous pouvez choisir quelles données autoriser, par exemple liste. Puis cliquez sur la zone source et tapez la liste des valeurs séparées par un point-virgule. Par exemple : France ; Belgique ; Allemagne. Vous pouvez également créer cette liste de valeurs par référence à une plage de cellules situées ailleurs dans le classeur.
Vérifiez que la case liste déroulante dans la cellule est cochée. Sinon, vous ne pourrez pas voir la flèche de la liste déroulant de la cellule.<br /><br />
 
[[File:Capture d’écran (9).png|validation des données 1]]<br /><br />
 
3{{e}} étape : Testez la validation des données pour vérifier qu’elle fonctionne correctement. Essayez d’entrer dans les cellules des données valides et non valides pour vérifier que vos paramètres fonctionnent et que les messages s’affichent de la façon escomptée.<br /><br />
 
[[File:Capture d’écran (10).png|validation des données 2]]
 
== Consolidation de données ==
Pour synthétiser, résumer, présenter et afficher des résultats de différentes feuilles de calcul, il est possible de consolider les données de chaque feuille dans une feuille unique. Ces nouvelles feuilles uniques peuvent être créées dans le même classeur en tant que «  feuille maître  » ou dans des classeurs différents.
 
Pour consolider des données, utilisez la commande Consolider du groupe Outils de données, sous l’onglet Données.
<br />
===Les différentes consolidations===
Plusieurs procédures existent en fonction de ce que vous souhaitez faire  :
* Consolidez par position si vous souhaitez organiser les données dans toutes les feuilles de calcul dans un ordre et à un endroit identique ;
* Consolidez par catégorie si vous souhaitez organiser les données différemment dans chaque feuille de calcul, mais utiliser les mêmes étiquettes de ligne et de colonne de sorte que la feuille de calcul maître puisse correspondre aux données;
* Consolidez par formule si vous souhaitez utiliser des formules contenant des références de cellules ou des référence 3D à d’autres feuilles de calcul que vous associez parce que vous ne disposez pas d’une position ou d’une catégorie fiable ;
* Utilisez un rapport de tableau croisé dynamique pour consolider les données à la place d'une consolidation.<br />​<br />​
 
Pour que la consolidation fonctionne :
:*Assurez-vous que chaque première ligne de chaque colonne contient une étiquette, chaque colonne contient des formats identiques, et la liste ne contient aucune ligne ou colonne vide.
:*Placez chaque plage dans une feuille de calcul différente. Ne placez aucune des plages dans la feuille de calcul sur laquelle vous allez placer la consolidation.
:*Nommez chaque plage d’un nom différent.<br /><br /><br />
 
{{Remarque|contenu=Attention ! La commande consolider remplit la zone de données nécessaire. Prenez soin de laisser suffisamment de cellules à droite et en dessous de cette cellule sélectionnée pour les données consolidées.}}
 
<br />
====Consolidation par position====
#Choisissez les données à consolider dans chaque feuille de calcul.
#Si la feuille de calcul est dans un autre classeur, cliquez sur Parcourir, à droite de la zone Référence pour choisir le fichier à consolider.
#Tapez le nom que vous avez attribué à la plage, puis cliquez sur Ajouter. Répétez cette étape pour chaque plage à consolider.
#Cliquez sur OK<br /><br />
{{Remarque|contenu=Attention ! Assurez-vous que toutes les plages ont la même disposition dans les feuilles}}
<br />
 
====Consolidation par catégorie====
#Si la feuille de calcul est dans un autre classeur, cliquez sur Parcourir, à droite de la zone Référence pour choisir le fichier à consolider.
#Tapez le nom que vous avez attribué à la plage, puis cliquez sur Ajouter. Répétez cette étape pour chaque plage à consolider.
#Cliquez sur OK<br /><br />
{{Remarque|contenu=Attention ! Assurez-vous que les étiquettes des colonnes ou des lignes que vous voulez associer ont la même orthographe et la même casse}}<br />
*Exemple : Les étiquettes "CA annuel" et "Chiffre d'affaires annuel" sont différentes et ne seront pas consolidées.
*Toutes les étiquettes qui ne correspondent pas à celles situées dans les autres zones source génèrent des lignes ou des colonnes distinctes dans la consolidation.
*Vérifiez si toutes les catégories que vous ne souhaitez pas consolider sont dotées d’étiquettes uniques qui n’apparaissent que dans une seule plage source.
<br />
====Consolidation par formule====
#Dans la feuille de calcul maître, insérez les étiquettes de ligne ou de colonne souhaitées pour les données consolidées.
{{Utilisateur:Mamagalubru/Cadre Astuce|astuce="Si le classeur est configuré pour calculer automatiquement les formules, la consolidation par formule est toujours mise à jour automatiquement lorsque les données de feuilles de calcul distinctes changent."}}
|}
<br />
====Rapport de tableau croisé dynamique====
Il est également possible de créer un tableau croisé dynamique à partir de plusieurs plages de consolidation. Cette méthode équivaut à la consolidation par catégorie, mais offre davantage de possibilités pour la réorganisation des catégories.
<br />
 
== Analyse de scénarios ==
 
 
<br />
=== Gestionnaire de scénarios ===
 
 
 
<br />
 
=== Valeur cible ===
 
« VALEUR CIBLE » permet de parvenir à un résultat souhaité qui est la « cible », par un ajustement de certaines valeurs. Les ajustements de données variables sont effectués par CALC une fois que le résultat souhaité, dit la valeur cible, a été indiqué
<br />
 
Pour atteindre la valeur cible :
# Dans le champ Cellule à définir, saisir la cellule à modifier. La formule qui doit être saisie dans la cellule à modifier doit utiliser la cellule à modifier.
# Dans le champ Valeur à atteindre, saisir le résultat souhaité, c'est-à-dire la valeur cible.
# Dans le champ Cellule à modifier, saisir la ou les cellule(s) que le tableur CALC ajustera pour atteindre la valeur cible.<br />[[File:Exemple valaur cible.jpg|400px|Exemple valaur cible]]<br /><br />​DansDans cet exemple, nous voulons CALC ajuste la cellule B5 « Nombre de mois » afin de calculer le montant des mensualités. Nous voulons rembourser l’emprunt avec des mensualités de {{unité|200|euros}}. Mais nous souhaitons garder comme taux d’intérêt 3.60%. Pour cela, CALC va modifier la valeur de la cellule B5 « Nombre de mois ».
# Après avoir cliqué sur OK, l’ « État de la recherche » fait apparaître le résultat suivant.
Le taux d'intérêt est inchangé. Les mensualités sont passées à {{unité|200|euros}} comme demandé et le nombre de mensualités passé de 108 mois à 54 mois.
<br />
 
=== Table de données ===
 
La table de données permet d’effectuer des calculs sur un ensemble de données. La table de données présente les différents résultats selon des données variables et offre une comparaison rapide des différents résultats.
<br />
 
Pour créer une table de données :
# Dans une cellule, entrez la formule qui utilise différentes données du tableau.
# Saisir différentes variables. Par exemple, différents taux d’intérêt.
# Sélectionnez la cellule comprenant la formule ainsi que les différents variables. Les résultats apparaissent à côté des données variables. Pour cela, sélectionnez également les cases vides à droite des cellules contenant les données variables.<br />[[File:Exemple table de données.jpg|300px|Exemple table de données]]
# Cliquez sur l’onglet Données puis sur le bouton Analyse scénarios. Enfin, cliquez sur Table de données.
# Indiquer la valeur d’entrée, c’est-à-dire la valeur de base qui permettra d’établir différents résultats<br />[[File:Création table de données.jpg|450px|Création table de données]]
# Dans la fenêtre « Table de données », deux choix sont possibles :<br />* Cellule d’entrée en ligne : si les variables sont en ligne, alors saisir la référence de la cellule d’entrée en ligne.<br />* Cellule d’entrée en colonne : si les variables sont en colonne (comme dans l’exemple ci-dessus), alors saisir la référence de la cellule d’entrée en colonne.<br />​DansDans cet exemple, la cellule d’entrée est la cellule J4 « Taux d’intérêt ». En effet, CALC va remplacer ce taux par les différentes variables (4,00%, 4,50%, etc.) afin d’avoir les différentes mensualités.
# Cliquez sur OK. Les différents résultats apparaissent dans les cellules vides à droite des variables.<br />[[File:Exemple table de données après validation.jpg|300px|Exemple table de données après validation]]
 
<br />
 
== Groupement de données ==
La fonctionnalité « Grouper » permet d’analyser des données en un sous-ensemble.
Cette fonction permet aussi de voir rapidement les sous-totaux.
La fonctionnalité « Grouper » regroupe les données par ligne ou par colonne.<br />
==== Créer un groupe de données ====
 
# Cliquez sur l’onglet « DONNEES »<br /><br />
# Sélectionnez les colonnes ou les lignes à regrouper<br /><br />​AttentionAttention : les colonnes et les lignes ne peuvent pas être regroupées ensemble<br />​DansDans l’exemple, nous sélectionnons les colonnes B à D.<br /><br />[[File:Sélection pour exemple grouper.jpg|200px|Sélection pour exemple grouper]]<br /><br />
# Cliques sur le bouton « Grouper » puis sur l'objet "Grouper"<br /><br /><br />
# La fenêtre suivante apparaît :<br /><br />[[File:Comment grouper.jpg|200px|Comment grouper]]<br /><br />​IlIl est possible de regrouper les données par :<br />* ligne (exemple : ligne 1 à ligne 5)<br />* colonne (exemple : colonne A à colonne E)<br />​CliquerCliquer sur le bouton OK<br />​CelaCela créera un premier niveau de regroupement des données.<br /><br />
# Les données sont regroupées par niveau : <br />* niveau 1 : premier sous-ensemble. Dans l’exemple, le niveau 1 correspond aux colonnes B à C<br />* niveau 2 : deuxième sous-ensemble. Il permet par exemple de regrouper des données dans le premier groupe existant (même méthodologie que pour créer un groupe de niveau 1)<br /><br />[[File:Exemple de données groupées en mode ouverture.jpg|300px|Exemple de données groupées en mode ouverture]]
<br /><br />
Une ligne suivie du signe « - » apparaît.
En cliquant sur le signe « - », les colonnes ou lignes se regroupent.
En cliquant sur le signe « + », les données se dégroupent et les colonnes apparaissent.<br /><br />
[[File:Exemple de données groupées.jpg|150px|Exemple de données groupées]]<br />
 
==== Dissocier un groupe de données ====
 
 
<br />
 
=== Insérer des sous-totaux ===
 
Grâce à CALC, il est possible de calculer automatiquement les sous-totaux et les totaux d’une colonne à l’aide de l’outil « Sous-Total » de l’onglet « Données » (Plan).
<br />
Il vous est possible d’effectuer deux actions différentes :
* Insérer un seul niveau de sous-totaux
* Insérer des sous-totaux imbriqués
<br />
Attention, pour que la commande « Sous-Total » fonctionne correctement, il faut que :
* Chaque colonne comporte une étiquette dans la première ligne.
* Chaque ligne contienne des informations similaires.
* Aucune ligne ou colonne de la plage de cellule ne soit vide.
<br />
====Insérer un seul niveau de sous-totaux.====
# Sélectionnez une cellule dans la plage de cellule à laquelle vous voulez ajouter des sous-totaux.
# Dans « Utilisez la fonction », choisissez la fonction que vous voulez utiliser pour calculer les sous-totaux (somme, moyenne…etc)
# Cliquez sur « OK »
<br />
 
====Insérer des sous-totaux imbriqués.====
# Effectuez de nouveau cette procédure, en prenant soin de décocher la case « Remplacer les sous-totaux existants » afin de ne pas écraser les anciens sous-totaux.
# Répétez l’étape (jusqu’à sept fois) afin d’obtenir le nombre de sous-totaux souhaité.
<br />
====Remarques====
* Pour définir un saut de page automatique après chaque sous-total, cochez la case « Saut de page entre les groupes »
234

modifications