Différences entre les versions de « SPARQL Protocol and RDF Query Language/Travail pratique/Initiation à Eclipse »

m
Robot : Remplacement de texte automatisé (- l'utilisation + l’utilisation , - d'asile + d’asile , - s'inspirer + s’inspirer , - l'expression + l’expression , - d'usage + d’usage , - d'autre + d’autre , - d'important + d’important...
m (Robot : Remplacement de texte automatisé (- l'utiliser + l’utiliser))
m (Robot : Remplacement de texte automatisé (- l'utilisation + l’utilisation , - d'asile + d’asile , - s'inspirer + s’inspirer , - l'expression + l’expression , - d'usage + d’usage , - d'autre + d’autre , - d'important + d’important...)
=== Les débogueurs PHP ===
Il n’y a que deux débogueurs pour PHP :
* {{w|Zend Framework|Zend}}, qui est intégré à la suite de développement payante Zend (à condition de disposer des serveurs de production également avec Zend sinon... bugs d’incompatibilités à prévoir)
* {{w|Xdebug}}, qui est gratuit, mais qui est moins simple à installer
 
Nous installerons donc XDebug, car les étudiants ont un budget relativement limité pour ce genre de dépenses.
=== Documentations ===
Ce TP a été fabriqué avec les documents suivants :
* [http://wiki.eclipse.org/PDT/Installation#From_Update_Site Eclipse 3.7 installation]
* [https://help.ubuntu.com/community/EclipseIDE#User%20installation Eclipse installation avec Ubuntu]
* [http://www.eclipse.org/pdt/documents/XDebugGuideForPDT2.0.pdf Configurer PDT]
* [http://docs.joomla.org/Extension_development_using_eclipse_and_phing#More_Phing_Examples Tutoriel Phing et Eclipse]
 
== Installation ==
</source>
{{remarque|contenu=
Si vous avez un souci, il y a de fortes chances que quelqu’un d'autred’autre ait déjà rencontré le même problème. <br />
N'hésitez pas à chercher la solution via un moteur de recherche ou à demander de l'aide sur les forums de développeurs PHP.
}}
 
Pour finir, on va créer un raccourci pour le mettre sur notre bureau :
# clic droit sur votre bureau
# créer un raccourci (ou create launcher)
# indiquer le nom : Eclipse
# indiquer le chemin du script (command) : /home/<your username>/opt/eclipse/eclipse
# cliquer sur l'icône pour indiquer le chemin du script de l'icône d'Eclipse : /home/<your username>/opt/eclipse/eclipse/icon.xpm
# cliquer sur OK
 
Vous pouvez maintenant double cliquer sur l’icône Eclipse sur votre bureau.
 
Eclipse s'ouvre et vous demande de préciser votre espace de travail, '''indiquer un autre répertoire que ~/projets'''. Cela évite un certain nombre de problèmes de configuration.
 
Dans Eclipse :
# Aller dans le menu : Help > Install New Software.
# Choisir le site (Work with) : "Indigo -- http://download.eclipse.org/releases/".
# Attendre que la liste soit mise à jour (attendez que le mot pending disparaisse).
# Aller ensuite dans langages de programmation.
# Cocher la liste PHP Development Tools (PDT).
# Cliquer sur Suivant deux fois.
# Cocher Accepter les licences.
# Cliquer sur Terminer.
 
Après l'installation, Eclipse vous demande de redémarrer :
Nous allons ouvrir ce projet et le configurer.
 
# Ouvrir Eclipse.
# Menu Fichier > Nouveau projet.
# Ouvrer PHP > projet PHP.
 
La boîte de dialogue "Nouveau projet" s'ouvre.
# Donner un nom au projet : MonCv.
# Cocher : Créer un projet de sources existantes.
# Rechercher la racine du répertoire créé dans le TP précédent : ~/projets/moncv .
# cliquer sur Terminer (Finish).
 
== Configurer la construction du projet ==
 
Pour ce faire :
# Faire un clic droit sur ​​le projet
# sélectionner Propriétés
# sélectionner Constructeurs (builder)
# cliquer sur Nouveau pour afficher la boîte de dialogue "Choisir le type de configuration"
# sélectionner Programme
# Cliquer sur OK
 
La boîte de dialogue pour créer une configuration s'est affichée :
# Donner un nom, par exemple : Phing build.xml
# Indiquer l'emplacement de l'exécutable (Location) : /usr/bin/phing
# Indiquer l'emplacement d’exécution (Working directory) :
## Cliquer sur le bouton Browse WorkSpace
## Sélectionner la racine où se trouve le fichier build.xml, ici MonCV
## Cliquer sur OK
 
L'emplacement d’exécution (Working directory) doit contenir quelque chose qui ressemble à :
 
Maintenant, on indique les moments d’exécution :
# Aller dans l'onglet Rafraîchir (Refresh).
# Cocher la case "Rafraîchir les ressources" (Refresh resources upon each completion).
# Cocher "Espace de travail en entier" (The entire Workspace).
# Aller dans l'onglet Options (Build Options).
# Cocher l'auto-construction (During auto-build).
 
Cliquer finalement sur le bouton OK pour refermer la boîte de dialogue.
Nous utiliserons le serveur Web que nous avons installé dans un précédent TP pour déboguer notre projet.
 
# Via le menu : Window > Preferences
# Ouvrir le nœud : PHP > PHP Servers
# Créer un nouveau serveur : MonCV
# Donner son domaine (base url) : {{lien brisé|consulté le=2014-09-20|url=http://moncv}}
# Donner la racine sur le disque du service Web (local Web root): /var/www/moncv
# Aller dans l'onglet Mapping
# Cliquer sur Nouveau
## Dans Chemin sur le serveur, indiquer : /var/www/moncv
## Cocher Chemin dans l'espace de travail
## Trouver la racine des sources, c'est-à-dire le répertoire src. Vous devez avoir comme résultat : MonCV/src
# Cliquer sur OK jusqu'à ce que toutes les boîtes de dialogues soient fermées
 
=== Indiquer le débogueur ===
| suivant = [[../Faire un serveur SPARQL/]]
}}
 
 
[[Catégorie:SPARQL Protocol and RDF Query Language]]
140 590

modifications