Différences entre les versions de « SPARQL Protocol and RDF Query Language/Travail pratique/Initiation à Eclipse »

m
Robot : Remplacement de texte automatisé (-\n(==={0,3})(?: *)([^\n=]+)(?: *)\1(?: *)\n +\n\1 \2 \1\n)
m (Robot : Remplacement de texte automatisé (- n'est pas + n’est pas , - Aujourd'hui + Aujourd’hui , - d'euros + d’euros , - d'agir + d’agir , - l'apparence + l’apparence ))
m (Robot : Remplacement de texte automatisé (-\n(==={0,3})(?: *)([^\n=]+)(?: *)\1(?: *)\n +\n\1 \2 \1\n))
}}
 
== Pourquoi utiliser Eclipse ? ==
Dans ce TP, nous allons installer Eclipse, ainsi que certains composants de [[w:Débogueur|débuggage]].<br />
{{w|Eclipse (projet)|Eclipse}} est l'un des logiciels les plus utilisés pour faire du développement Web et il est gratuit.<br />
Ce TP a pour objectif de vous en montrer les avantages, mais aussi de vous faire gagner du temps sur l'installation du débuggeur, qui est indispensable à tout vrai développeur professionnel.
 
== À savoir avant de commencer ==
=== Les débogueurs PHP ===
Il n’y a que deux débogueurs pour PHP :
Nous installerons donc XDebug, car les étudiants ont un budget relativement limité pour ce genre de dépenses.
 
=== Documentations ===
Ce TP a été fabriqué avec les documents suivants :
* [http://wiki.eclipse.org/PDT/Installation#From_Update_Site Eclipse 3.7 installation]
* [http://docs.joomla.org/Extension_development_using_eclipse_and_phing#More_Phing_Examples Tutoriel Phing et Eclipse]
 
== Installation ==
 
=== Débogueur : XDebug ===
Il y a autant de manières d'installer XDebug qu’il y a de version de Linux.
 
L'installation suivante sera faite avec la version Ubuntu 10.04.3. Si ce n’est pas votre version, n'hésitez pas à comparer cette installation avec les résultats fournis par un moteur de recherche quand vous recherchez le nom de votre distribution Linux avec sa version et XDebug.
 
==== Ubuntu 10.04.3 ====
Installez le composant php5-xdebug.
<source lang="bash">
}}
 
=== Java Runtime Environment ===
Il n’est pas conseillé d'installer Eclipse via <code>apt-get</code>, il faut installer le JRE (Java Runtime Environment) séparément.
 
}}
 
=== Eclipse ===
En fonction de la version de votre JRE, 32 ou 64 bits, vous choisirez la dernière version de "Eclipse Classic" x86 ou x86_64 : http://www.eclipse.org/downloads/
 
Eclipse s'ouvre et vous demande de préciser votre espace de travail, '''indiquer un autre répertoire que ~/projets'''. Cela évite un certain nombre de problèmes de configuration.
 
=== Configurer la source des mises à jour et des plug-ins d'Eclipse ===
Dans Eclipse :
# aller dans le menu : Help > Install New Software.
Vous pouvez maintenant installer les plug-ins PHP et Web.
 
=== Installer le plug-in PHP ===
 
Dans Eclipse :
* cliquer sur "redémarrer maintenant"
 
=== Installer le plug-in Web ===
 
# aller dans le menu : Help > Install New Software .
* Cliquer sur "Redémarrer maintenant".
 
== Ouvrir votre projet PHP dans Eclipse ==
Nous avons, dans le projet précédent, utilisé PHPUnit et créé l'arborescence de fichier du projet nommé MonCV.
Nous allons ouvrir ce projet et le configurer.
# cliquer sur Terminer (Finish).
 
== Configurer la construction du projet ==
Nous allons utiliser Phing pour construire le projet automatiquement afin de permettre de le débugger.
 
Cliquer finalement sur le bouton OK pour refermer la boîte de dialogue.
 
== Configurer le débogueur ==
=== Indiquer le serveur utilisé pour débugger ===
Nous utiliserons le serveur Web que nous avons installé dans un précédent TP pour déboguer notre projet.
# Cliquer sur OK jusqu'à ce que toutes les boîtes de dialogues soient fermées
 
=== Indiquer le débogueur ===
# Via le menu : Window > Preferences
# Cliquer sur le nœud : PHP > Debug
# Cliquer sur OK pour fermer la fenêtre
 
== Débugguer une page Web ==
 
=== Créer une page Web ===
 
Nous allons créer une page PHP dans le répertoire src :
Sauvegarder, dans le menu : File > Save (ou Ctrl + s )
 
=== Insérer un point d'arrêt ===
 
Un point d'arrêt est un point placé à un endroit spécifique d'un programme qui permet d'indiquer à un débogueur d'arrêter l'exécution lorsqu’il atteindra cet endroit.
Ce point d'arrêt nous sera utile dans l'exercice suivant.
 
=== Créer un profil de débogage ===
 
Un site Web est composé de plusieurs fichiers PHP qui peuvent être autant de points d'entrée dans votre site.
Si ce n’est pas le cas, indiquez XDebug et le serveur moncv}}
 
=== Débugger ===
 
Eclipse a plusieurs modes d'affichage. Il y en a un pour PHP et un pour débugger. Eclipse vous demandera souvent de passer d'un mode à un autre automatiquement.
140 590

modifications